1. 首页
  2. 全部文档
  3. 无代码图形化编程手册
  4. 开始开发(5节)
  5. 工具常用操作

工具常用操作

新建项目

本地运行和停止运行项目

导出项目

导入项目

删除项目

更换项目文件夹

更换本地运行浏览器

打开属性窗口

 

 

新建项目

  • 直接快捷键“Alt+Shift+n”,弹出浮动窗口中选“Tersus Project”
  • 可以英文菜单点击“File-New-Tersus Project”来打开新建项目窗口,中文菜单点击“文件-新建-Tersus Project”来打开新建项目窗口
  • 以上第二种方式时可以用Alt键激活菜单首字母再点字母去选择
  • 新建项目时,在当前工具使用的项目文件夹中生成项目文件夹及子文件夹和开发文件

以下为英文菜单新建项目示意图:

以下为中文菜单新建项目示意图:

  • 新建项目窗口中进行项目命名和模板选择,命名注意用拼音或英文或数字及其组合,不可用中文,模板请选新移动应用模板“New Mobile Application”,这是开发手册和教学中使用的模板
  • 新建完成后,默认在开发区中打开新建项目,直接进入新项目设计开发,也可直接在本地运行新项目

以下为新项目命名和模板选择示意图:

 

本地运行和停止运行项目

  • 软件项目在开发区中打开并是当前编辑的窗口对应的项目时,即可点击菜单栏中的按钮工具条中“绿三角运行按钮”在本地浏览器运行查看开发结果,可以在本地输入数据进行功能测试
  • 运行中的项目可以点击菜单栏中的按钮工具条中“红方块按钮”停止运行
  • 注意如果本地运行时并不成功启动浏览器显示开发结果,则可能是开发者电脑中未定义默认浏览器,也可以在开发工具中设定非默认运行的浏览器为本地运行测试浏览器,请参考本节中“更换本地运行浏览器”部分的内容

以下为菜单栏中工具条运行和停止运行按钮示意图:

 

导出项目

  • 在TERSUS开发工具的左侧项目目录区中,右键单击要导出的项目名称,然后英文菜单选“Export”,中文菜单选“导出”即可;也可以直接选开发工具菜单栏中的“文件-导出”或“File-Export”,然后弹出的导出弹窗中先选中要导出的项目名称再进一步选目标文件夹地址即可导出项目
  • 注意常用的是导出为一个TERSUS项目文件,其他类型如导出项目文件夹可以自行选用
  • 此方式不能导出Native App也就是移动应用文件包或资源包,应使用菜单栏中按钮工具中导出移动应用按钮进行移动应用文件的导出操作(参考“移动端开发手册”相关内容)
  • 导出移动应用的按钮为示意图中小箭头的黑色小块按钮,下面英文菜单示意图中是工具条中最后一个按钮,下面中文菜单示意图中是工具条中第5个按钮
  • 导出窗口最后一步中可以选择导出地址同时可重命名导出的文件名,建议名称中直接加个日期序号作为同一项目不同日期的备份文件
  • 导出窗口最后一步中可以勾选是否同步保存本地测试数据文件(如果有的话),保存后下次导入时测试数据仍会在项目文件夹的数据库文件中

以下为英文菜单下导出软件项目的示意图:

以下为中文菜单下导出软件项目的示意图:

 

导入项目

  • 英文菜单栏中点击“File-Import”、中文菜单栏中点击“文件-导入”,弹出窗口中先选要导入的项目类型(一般为Tersus Project File,和导出时一致),参考以下示意图;
  • 可以用Alt键激活菜单首字母再点字母去选择
  • 选择导入项目类型后,选择已备份或其他已有的项目所在文件夹及文件,可以进一步在此重命名为导入后的新项目名称
  • 以新名称导入后,需要对项目中模型Model名称右键单击同样进行重命名,否则项目名与模型名不一致,双击项目名就无法在开发区打开项目(双击模型及以下开发对象可以随意打开进行编辑)

以下为英文菜单下导入软件项目的示意图:

以下为中文菜单下导入软件项目的示意图:

 

删除项目

  • 在TERSUS开发工具的左侧项目目录中,右键单击要删除的项目名称,然后英文菜单选“Delete Delete”,中文菜单选“Delete 删除”即可弹出删除弹窗
  • 注意如果要删除一个项目,需先停止项目,并关闭开发区中打开的所有此项目内容的开发窗口,停止项目请参考本节“本地运行和停止运行项目”部分的内容
  • 如果删除项目时弹出弹窗显示删除不成功,主要原因就是项目仍在运行中,或是开发区窗口至少有一个此项目的开发窗口正在打开,此时需先半闭开发工具,去开发者电脑硬盘的项目文件夹中手动删除项目名称的项目文件夹(参考本节“更换项目文件夹”部分内容),再重新运行TERSUS开发工具,在左侧项目目录中再操作一次删除处理以删除残余内容

以下为英文菜单下删除软件项目的示意图:

以下为中文菜单下删除软件项目的示意图:

更换项目文件夹

  • 英文菜单中点击“File-Switch Workspace-Other”弹出新项目文件夹地址选择窗口,中文菜单中点击“文件-切换工作间-其他”即可
  • 可以用Alt键激活菜单首字母再点字母去选择
  • 注意新文件夹地址选择窗口中选中新的文件夹,确认修改项目文件夹后,会自动重启开发工具
  • TERSUS开发工具安装完成后,默认的项目文件夹是在安装文件下的“Workspace”文件夹,安装时默认自带的案例项目也是在这个文件夹中的
  • 开发工具软件安装时默认是安装在系统盘(如C盘),在Win10等系统下,如果工具的打开方式不是以管理员方式打开,则会因非管理员用户不能修改系统盘文件,所以提示项目文件夹不可用或已占用,此时必须更换“项目文件夹”
  • 注意更换项目文件夹时,需以管理员方式打开开发工具再进行更换,所以首次安装后运行打开有可能不是管理员方式,最好的办法是,安装完成后,关闭开发工具,重新以管理员方式打开工具(打开程序中右键单击选管理员方式打开)再更换“项目文件夹”

以下为英文菜单下切换项目文件夹示意图:

以下为中文菜单下切换项目文件夹示意图:

更换本地运行浏览器

  • 菜单中点击Windows—Preferences
  • 在弹出窗口中展开General,点选Web Browser
  • 默认是勾选使用默认浏览器的,默认浏览器是用户在电脑的操作系统默认项中设定的,比如Win 10系统在“开始-设置”功能中设定
  • 可以点New来添加已安装在开发者电脑中的其他浏览器,输入名称和浏览器在电脑中安装的位置就可以
  • 勾选要使用的浏览器后,点Apply应用,点OK关闭弹窗

以下为动画示意图:

 

打开属性窗口(工具中各类窗口未显示时同样方式重新打开)

  • 开发过程中,有时会关闭开发区下部的属性窗口或其他窗口,可以在菜单中重新打开
  • 英文菜单点击“Window-Show View-Properies”来重新打开,中文菜单点击“窗口-显示视图-属性”来重新打开
  • 用快捷键处理时,先按“Alt”激活菜单首字母选择功能,然后按“W”—按“V”—按“P”—再按“P”,点回车按键就可以了,注意中文菜单时,因为最后一级的快捷键未设定,只能用鼠标选择

以下为英文菜单时打开属性窗口示意图:

以下为中文菜单时打开属性窗口示意图: